We're having some trouble with our Sign services

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 12:47 PDT

Monitoring

A fix has been implemented and we are monitoring this issue.
Posted Jul 31, 2025 - 12:13 PDT

Update

We are continuing to work on a fix for this issue.
Posted Jul 31, 2025 - 12:07 PDT

Identified

We're having some trouble with our Sign services. We're working to fix the problem as quickly as we can.
Posted Jul 31, 2025 - 10:42 PDT
This incident affected: Core (Send signature requests, Finished document delivery), Web (Document signing through Dropbox Sign and Fax, Embedded signing through Dropbox Sign), and API (API callbacks from Dropbox Sign).