Site instability
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Jul 29, 2020 - 16:24 PDT
Update
The issue is now resolved. Web pages and API calls are back to normal response times.
Posted Jul 29, 2020 - 16:24 PDT
Monitoring
A fix has been implemented and we're monitoring the results.
Posted Jul 29, 2020 - 15:54 PDT
Identified
We are currently experiencing site instability. We have identified the issue and are working to resolve it. You're likely to experience failures in page loading and API calls.
Posted Jul 29, 2020 - 15:36 PDT
Investigating
We are currently experiencing site instability. We have identified the issue and are working to resolve it. You're likely to experience failures in page loading and API calls.
Posted Jul 29, 2020 - 14:52 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.