Some users may not be able to complete Signature Request in Dropbox web

Incident Report for Dropbox Sign, Fax, and Forms

Resolved

This incident has been resolved
Posted 2 years ago. May 03, 2023 - 10:33 PDT

Identified

The issue has been identified and a fix is being implemented
Posted 2 years ago. May 02, 2023 - 16:18 PDT

Investigating

Some users may not be able to complete Signature Request in Dropbox web. We're investigating and working to find a resolution. Thank you for your patience.
Posted 2 years ago. May 02, 2023 - 09:38 PDT
This incident affected: Web (Document signing through Dropbox Sign and Fax).