Excessive site response times
Incident Report for HelloSign / HelloFax
Resolved
Performance is back where we expect it to be, we do not anticipate this issue returning.
Posted 5 months ago. Feb 20, 2019 - 11:37 PST
Monitoring
Our recovery plan has been implemented, and signs are looking quite promising. Response times are returning to normal, and backlogs are processing.
Posted 5 months ago. Feb 20, 2019 - 10:46 PST
Identified
We have isolated the system responsible for the delays and intermittent timeouts, and are working on a recovery plan.
Posted 5 months ago. Feb 20, 2019 - 10:20 PST
Investigating
We are investigating the source of excessive delays in site and API response times. This includes UI, API, and Salesforce.
Posted 5 months ago. Feb 20, 2019 - 09:28 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.