Document delivery delay
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved. Thank you for your patience!
Posted Jun 19, 2019 - 08:55 PDT
Monitoring
A fix has been implemented. Delays are reduced. We are monitoring this actively.
Posted Jun 19, 2019 - 08:43 PDT
Investigating
Deliveries of documents is currently delayed. We have identified the cause and are working to get deliveries resumed. Thank you for your patience.
Posted Jun 19, 2019 - 08:36 PDT
This incident affected: HelloSign and HelloFax.