Incoming HelloFax document status issues

Incident Report for Dropbox Sign, Fax, and Forms

Resolved

All affected faxes should now be visible in the Faxes page. Thank you for your patience.
Posted Sep 09, 2022 - 16:48 PDT

Update

Until we finish repopulating, faxes affected by this issue can still be accessed through use of the link in email.
Posted Sep 09, 2022 - 12:43 PDT

Monitoring

New faxes will now show up in the faxes page. Older faxes affected by this issue will be populating over the next few hours.
Posted Sep 09, 2022 - 12:00 PDT

Identified

We have identified the issue preventing faxes from appearing on the documents page, and are working on a fix.
Posted Sep 09, 2022 - 11:09 PDT

Investigating

We are investigating reports of received faxes not appearing on the Faxes page. Fax receipt and delivery is working as expected. This does not affect HelloSign or HelloWorks.
Posted Sep 09, 2022 - 10:07 PDT