Embedded HelloSign signing is currently unavailable
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
Our investigation of the cause has concluded, and we believe the problem is addressed in a stable manner.
Posted Apr 19, 2018 - 14:40 PDT
Monitoring
We believe our vendor has corrected the issue. It appears the embedded signing issue may have been limited to our demonstration systems.
Posted Apr 19, 2018 - 14:09 PDT
Identified
Due to a problem with one of our vendors, embedded signing is currently unavailable. We are working on a workaround. Thank you for your patience.
Posted Apr 19, 2018 - 13:58 PDT