Delayed inbound faxes
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted Jul 03, 2018 - 10:58 PDT
Update
The delay in the processing of inbound faxes has been resolved.
Posted Jul 03, 2018 - 07:57 PDT
Investigating
We are currently investigating a delay in the processing of inbound faxes.
Posted Jul 03, 2018 - 07:45 PDT