Error Sending Faxes - HelloFax
Incident Report for HelloSign / HelloFax
Resolved
We have patched the issue and can confirm the issue has been fixed. Impacted faxes can be re-sent using the "Edit and Resend" button found on the Faxes page. We apologize for any inconvenience caused, and if you have any questions please reach out to us at: support@hellofax.com
Posted 4 months ago. Mar 29, 2019 - 11:04 PDT
Investigating
We have a service disruption with outbound faxing in the Americas region. We have figured what is causing this and are actively working on fixing this. We will update this incident when we have more updates.
Posted 4 months ago. Mar 29, 2019 - 10:51 PDT
This incident affected: HelloFax.