Delayed Document & Upload Processing
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Apr 23, 2020 - 13:29 PDT
Monitoring
We have identified root-cause and are monitoring.
Posted Apr 23, 2020 - 07:56 PDT
Investigating
Document conversion & upload, and some site functions are operating slowly.
Posted Apr 23, 2020 - 07:47 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.