Intermittent issues
Incident Report for HelloSign / HelloFax
Resolved
The incident has been resolved. Thank you for your patience.
Posted Mar 17, 2021 - 16:38 PDT
Investigating
We’re currently experiencing a recurrence of intermittent service outages on our HelloSign and HelloFax platforms. We are actively working on a resolution and will update you as soon as possible. We apologize for any inconvenience and appreciate your patience as our team urgently works on this!
Posted Mar 17, 2021 - 15:52 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.