Site responsiveness issues
Incident Report for HelloSign / HelloFax
Resolved
This incident is resolved.
Posted Oct 07, 2020 - 14:33 PDT
Monitoring
We have identified the event causing the responsiveness problems and are monitoring further developments. We expect no further additional problems.
Posted Oct 07, 2020 - 14:27 PDT
Investigating
We are investigating reports of site responsiveness problems.
Posted Oct 07, 2020 - 14:22 PDT
This incident affected: HelloSign, HelloFax, HelloSign API, and HelloWorks API.