HelloSign/Fax site slowness
Incident Report for HelloSign / HelloFax
Resolved
The identified issue has been remediated. We consider this incident resolved.
Posted Oct 16, 2019 - 10:12 PDT
Identified
We have identified one source of load and are remediating it. Site performance should be improving. Document conversions are no longer backlogged.
Posted Oct 16, 2019 - 09:56 PDT
Update
Document uploads are now impacted. They are slow, and may time-out when uploaded through the UI.
Posted Oct 16, 2019 - 09:28 PDT
Investigating
We are experiencing an unexpected load, which is causing site slowness. We are investigating. HelloWorks should be minimally affected.
Posted Oct 16, 2019 - 09:19 PDT
This incident affected: HelloSign, HelloFax, HelloSign API, and HelloWorks API.