Investigating file uploads

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 11:28 PDT

Update

We are continuing to monitor for any further issues.
Posted Aug 31, 2026 - 11:18 PDT

Monitoring

A fix has been implemented, files should be uploading normally and we are monitoring.
Posted Aug 31, 2026 - 11:02 PDT

Investigating

We’re investigating reports of degraded performance with file and image uploads. Some uploads may be slower than expected or intermittently fail. Our engineering team is actively investigating.
Posted Aug 31, 2026 - 10:34 PDT
This incident affected: Core (Send signature requests) and Web (Document signing through Dropbox Sign and Fax, Embedded signing through Dropbox Sign).