Delays in document and signature actions
Incident Report for HelloSign / HelloFax
Resolved
Today's incident is resolved.
Posted Oct 09, 2020 - 16:02 PDT
Monitoring
Performance improvements are in place, monitoring continues. Resolution is being tracked with our cloud provider.
Posted Oct 09, 2020 - 13:40 PDT
Update
Document generation for HelloWorks is affected by this event. Documents will be retried later today.
Posted Oct 09, 2020 - 11:02 PDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 09, 2020 - 10:52 PDT
Update
Little has changed since our last update, site performance remains poor. We are continuing to work with our cloud provider to track a resolution.
Posted Oct 09, 2020 - 10:38 PDT
Update
We are continuing to work with our cloud provider to track a resolution, and apologize for the troubles.
Posted Oct 09, 2020 - 09:33 PDT
Update
We are continuing to work with our cloud provider to track a resolution, though are building workarounds to solve the immediate problems.
Posted Oct 09, 2020 - 08:56 PDT
Update
Signature request delivery and document finalizations are responding normally, but we are still experiencing site and API availability issues. We are continuing to work with our cloud provider for a resolution.
Posted Oct 09, 2020 - 08:24 PDT
Update
We are continuing to work with our cloud provider to track a resolution.
Posted Oct 09, 2020 - 07:46 PDT
Update
We are seeing some improvements in performance, but are continuing to work closely with our cloud provider to track resolution.
Posted Oct 09, 2020 - 07:09 PDT
Update
We are continuing to work with our cloud provider to track a resolution.
Posted Oct 09, 2020 - 06:30 PDT
Identified
We have identified an issue with our cloud provider, and are working closely with them to track resolution.
Posted Oct 09, 2020 - 06:03 PDT
Investigating
We are currently investigating delays in document conversion and signature request delivery.
Posted Oct 09, 2020 - 05:48 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.