Recent Dropbox Sign Security Incident
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted May 16, 2024 - 12:52 PDT
Investigating
Some customers may be experiencing disruption as the result of a security incident. We sincerely apologize for the inconvenience. Please go here for more information: https://sign.dropbox.com/blog/a-recent-security-incident-involving-dropbox-sign
Posted May 01, 2024 - 13:38 PDT
This incident affected: Core (Send signature requests, Form sending through Dropbox Forms), API (API callbacks from Dropbox Sign, API callbacks from Dropbox Forms), and Integrations (Salesforce, HubSpot).