HelloSign Connectivity Issue
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Oct 21, 2021 - 12:03 PDT
Update
Performance restored, monitoring continues.
Posted Oct 20, 2021 - 11:47 PDT
Monitoring
A contributing cause has been identified and a fix applied, monitoring.
Posted Oct 20, 2021 - 11:34 PDT
Investigating
Performance is presently degraded, investigating.
Posted Oct 20, 2021 - 11:03 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.