Signature requests experiencing misplaced/missing fields and signatures
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted Sep 14, 2023 - 17:47 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 14, 2023 - 11:31 PDT
Update
We apologize for the delay on this issue, we’re still actively investigating. Thanks for your patience.
Posted Sep 14, 2023 - 08:32 PDT
Update
Our team is still investigating these reports, and we'll continue to provide updates as we have them. This issue is not wide spread and most documents are unaffected.
Posted Sep 13, 2023 - 22:54 PDT
Update
Investigation still in progress. Thanks for your patience.
Posted Sep 13, 2023 - 20:27 PDT
Update
We are continuing to investigate and will reach out with another update shortly.
Posted Sep 13, 2023 - 19:10 PDT
Update
We are continuing to investigate the issue.
Posted Sep 13, 2023 - 18:41 PDT
Investigating
We are currently receiving reports of some users experiencing misplaced/missing fields and signatures in some of their requests. We are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Sep 13, 2023 - 18:09 PDT
This incident affected: Web (Document signing through Dropbox Sign and Fax).