Performance problems - site and API
Incident Report for HelloSign / HelloFax
Resolved
We have completed our recovery the small percentage of documents processed between 0300 and 1300 UTC on May 5 that were affected by this event. Not all documents or faxes were able to be recovered. If your document is affected, please resend the document.
Posted May 05, 2022 - 19:24 PDT
Monitoring
Performance has been normal since our previous update. A small percentage of documents processed between 0300 and 1300 UTC today encountered an error that prevented finalization, which includes both HelloSign and HelloFax documents. We are working to recover these documents.
Posted May 05, 2022 - 16:05 PDT
Identified
We have taken steps to ensure that newly uploaded documents, created signature requests, and finalized documents will perform as usual. Documents and signature requests that have not yet arrived after some time, will continue to be delayed while we work to isolate a fix. We are setting our components to operational because we have high confidence that new workflows are no longer affected.
Posted May 05, 2022 - 09:35 PDT
Update
We are continuing to identify the cause and the fix.
Posted May 05, 2022 - 08:46 PDT
Investigating
We are currently investigating performance problems with our site and API endpoints. The site is operational, but performing outside of our expectations.
Posted May 05, 2022 - 08:09 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.