Delays in document processing
Incident Report for HelloSign / HelloFax
Resolved
The backlog is processed, site responsiveness is back to usual, and jobs should be processing as normal.
Posted Mar 20, 2020 - 10:23 PDT
Update
The condition causing the delay appears to be clearing, but we have a significant backlog to process. Document and signature status in 'sending' or 'pending' states will move after this backlog is cleared.
Posted Mar 20, 2020 - 10:04 PDT
Identified
We are currently experiencing significant delays in sending new signature requests and finalizing documents. We have identified the problem and are working on a remediation.
Posted Mar 20, 2020 - 09:53 PDT
This incident affected: HelloSign and HelloFax.