Site and API slowness in HelloFax/HelloSign
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
Systems have been stable since the S3 problem was cleared by Amazon. We are considering this incident resolved.
Posted Mar 20, 2018 - 11:52 PDT
Monitoring
The S3 outage has cleared, and our backlog has processed. Also, Amazon has updated their status pages to indicate their problem has been resolved. We will continue to monitor the situation, but performance has returned to normal.
Posted Mar 20, 2018 - 09:59 PDT
Update
We are showing signs that the S3 blockage is clearing. As is usual during such recoveries, we are processing a large backlog of traffic. This itself will slow us a for a short time, but we seem to be on the road to recovery.
Posted Mar 20, 2018 - 09:05 PDT
Update
HelloWorks flow generation and retrieval is affected by this incident.
Posted Mar 20, 2018 - 08:50 PDT
Update
Amazon has confirmed that S3 is currently experiencing an event in the US-East-1 region.
Posted Mar 20, 2018 - 08:40 PDT
Identified
We've identified the failing component, which appears to be Amazon S3 in the 'US Standard' zone. The Amazon status-pages do not yet show an outage, but the pattern we're seeing is consistent with an outage of that nature. We are watching things closely, but we are functionally down at this time.
Posted Mar 20, 2018 - 08:29 PDT
Investigating
We are currently experiencing excessive latencies in requests to the HelloSign and HelloFax web application and APIs. At this time, HelloWorks appears unaffected.
Posted Mar 20, 2018 - 08:21 PDT