Intermittent service outages
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 18:04 PDT
Update
A fix has been deployed, and we are monitoring the impacts.
Posted Apr 29, 2021 - 14:28 PDT
Monitoring
A fix has been deployed, and we are monitoring the impacts.
Posted Apr 29, 2021 - 14:28 PDT
Investigating
We’re currently experiencing intermittent service outages on our signer page loading times. We are actively working on a resolution and will update you as soon as possible. We apologize for any inconvenience and appreciate your patience as our team urgently works on this!
Posted Apr 29, 2021 - 13:37 PDT
This incident affected: HelloSign, HelloSign for Salesforce, and HelloFax.