Site and API slowness in HelloFax/HelloSign
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
Response-times have returned to normal, and look to stay that way. We apologize for the inconvenience.
Posted Mar 20, 2018 - 06:30 PDT
Monitoring
The incident appears to have been relatively brief, though wide-spread, and involved in our network provider. Response-times are returning to normal.
Posted Mar 20, 2018 - 06:17 PDT
Investigating
The HelloSign and HelloFax sites and APIs are currently experiencing excessive latencies. We are investigating the cause.
Posted Mar 20, 2018 - 06:05 PDT