Delays in site-response and document rendering
Incident Report for HelloSign / HelloFax
Resolved
The backlog has been worked, site performance should be back to usual. Thank you for your patience.
Posted Nov 19, 2019 - 08:50 PST
Monitoring
The cause of the slowdown has been identified, and we are recovering. Performance will be slow while we process the backlog, but should clear relatively soon.
Posted Nov 19, 2019 - 08:41 PST
Investigating
We are currently experiencing a slowdown in page loading, and rendering documents in our editor. This impacts both HelloFax and HelloSign, including their APIs. HelloWorks may experience slowdowns in document deliveries.
Posted Nov 19, 2019 - 08:20 PST
This incident affected: HelloSign, HelloFax, HelloWorks, and HelloSign API.