Sign is not working as expected for some users

Incident Report for Dropbox Sign, Fax, and Forms

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 04:44 PDT

Investigating

We are currently experiencing some issues in Sign. We are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Jul 15, 2025 - 03:06 PDT
This incident affected: Core (Send signature requests) and Web (Document signing through Dropbox Sign and Fax, Embedded signing through Dropbox Sign).