HelloSign/Fax Site Slowness
Incident Report for HelloSign / HelloFax
Resolved
Thank you for your patience. This issue is now resolved.
Posted Oct 30, 2019 - 15:38 PDT
Update
Services are operational. Sincere apologies for the degraded performance you may have encountered.
Posted Oct 30, 2019 - 14:55 PDT
Monitoring
The issue has been addressed, and relevant services are being monitored actively.We apologize for the increased latency you may have encountered over the course of this event.
Posted Oct 30, 2019 - 14:48 PDT
Identified
We've identified a viable cause for the latency and are implementing fixes accordingly
Posted Oct 30, 2019 - 12:08 PDT
Investigating
At this time, we are experiencing degraded services on our Hellosign and Hellofax platforms. Service is operational but may be latent or degraded in quality. We are actively working on a resolution and will update you as soon as possible.
Posted Oct 30, 2019 - 10:28 PDT
This incident affected: HelloSign, HelloFax, and HelloSign API.