Vendor Issue
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Dec 07, 2021 - 15:02 PST
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 15:02 PST
Update
We are continuing to investigate this issue.
Posted Dec 07, 2021 - 08:06 PST
Investigating
We’re currently experiencing degraded services on our (HS/HF/API/SFDC/HW) platform. Service is operational but may be degraded in quality. We are actively working on a resolution and will update you as soon as possible. We appreciate your patience as our team urgently works on this!
Posted Dec 07, 2021 - 08:02 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.