Issues detected with both logging in and sending signature requests

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Oct 01, 2025 - 07:55 PDT

Investigating

We are currently experiencing issues with both logging in and the sending signature requests flow. We are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Oct 01, 2025 - 06:55 PDT
This incident affected: Core (Send signature requests).