Increased latency and document delivery times
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 05, 2019 - 08:33 PDT
Update
We believe we've identified the root cause. Performance is improving, but there are still delays in signature request and fax delivery while we work through the backlog.
Posted 5 months ago. Jun 05, 2019 - 07:49 PDT
Investigating
We are currently investigating the issue.
Posted 5 months ago. Jun 05, 2019 - 07:33 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.