API response time issues
Incident Report for HelloSign / HelloFax
Resolved
The service has been healthy since our last update, and we have confidence the issue will not reoccur. Thank you for your patience.
Posted Nov 16, 2021 - 15:47 PST
Monitoring
We have exited emergency mode, and it was quite successful in helping us resolve the loading issues. Signature requests should be processing in their usual times now. We have identified areas of improvement to help us avoid this situation in the future. We will continue to monitor the system to make sure this is truly resolved.
Posted Nov 16, 2021 - 14:13 PST
Update
We are going to be entering emergency mode for a short time in order to adjust resources to handle increased loading. We apologize for this inconvenience, but this should shorten the overall event.
Posted Nov 16, 2021 - 13:13 PST
Update
We are continuing to work on addressing these issues, but expect the issues to remain for more time. We apologize for how long this is taking, but this is our top priority.
Posted Nov 16, 2021 - 12:21 PST
Update
We are continuing to work on addressing these issues, but we expect the issues to remain for at minimum one more hour. Outbound faxes and signature requests sent through API and the user interface are currently highly backlogged. All signature requests will be sent though.
Posted Nov 16, 2021 - 11:22 PST
Update
We are continuing to work on addressing these issues. Outbound faxes for HelloFax are also seeing significant delays. All signature requests are queued and will eventually be tried.
Posted Nov 16, 2021 - 10:23 PST
Identified
HelloSign and HelloFax are experiencing significant delays in API processing time, which started about 16:25 UTC. We have identified the issue and are working towards a resolution.
Posted Nov 16, 2021 - 09:42 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.