Intermittent service outages
Incident Report for HelloSign / HelloFax
Resolved
The fix is working as expected, and we are caught up with our backlog. This is resolved.
Posted Mar 17, 2021 - 15:07 PDT
Monitoring
A fix has been implemented, and we are watching the backlog. We expect full resolution soon.
Posted Mar 17, 2021 - 14:55 PDT
Investigating
We’re currently experiencing intermittent service outages on our HelloSign and HelloFax platforms. We are actively working on a resolution and will update you as soon as possible. We apologize for any inconvenience and appreciate your patience as our team urgently works on this!
Posted Mar 17, 2021 - 14:37 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.