Degraded service
Incident Report for HelloSign / HelloFax
Resolved
The issue has been resolved and document generation is back to normal
Posted 2 months ago. Feb 20, 2019 - 11:43 PST
Monitoring
We have identified the issue and have implemented a fix. We will continue to monitor the performance.
Posted 2 months ago. Feb 20, 2019 - 10:30 PST
Investigating
HelloWorks is experiencing an intermittent delay in generating documents. We are investigating the issue.
Posted 2 months ago. Feb 20, 2019 - 09:48 PST
This incident affected: HelloWorks.