Delays in document deliveries
Incident Report for HelloSign / HelloFax
Resolved
Systems remain stable. We consider the incident resolved.
Posted 4 months ago. Mar 16, 2019 - 13:00 PDT
Monitoring
Our engineered discovered a way to flush the backlog faster, which has been done. Document deliveries should deliver on their usual schedule. Thank you for your patience.
Posted 4 months ago. Mar 16, 2019 - 12:39 PDT
Update
The issue has been identified, and the backlog is processing. Delays will continue for at least another 45 minutes.
Posted 4 months ago. Mar 16, 2019 - 12:19 PDT
Identified
Deliveries of documents is currently delayed. We have identified the cause and are working to get deliveries resumed. Thank you for your patience.
Posted 4 months ago. Mar 16, 2019 - 11:38 PDT
This incident affected: HelloSign, HelloFax, and HelloWorks.