HelloSign: Elevated error rates for some users.
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted 25 days ago. May 31, 2019 - 10:35 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 25 days ago. May 31, 2019 - 09:45 PDT
Identified
An issue in our rate limiter is currently resulting in a high rate of error responses for some customers. We've identified the issues and we'll be releasing a fix.
Posted 25 days ago. May 31, 2019 - 09:15 PDT
This incident affected: HelloSign.