HelloSign/Fax site slowness
Incident Report for HelloSign / HelloFax
Resolved
Site operations have returned to normal
Posted Sep 28, 2020 - 17:37 PDT
Update
We've exited emergency maintenance. HelloSign and HelloFax are up and degraded.
Posted Sep 28, 2020 - 16:42 PDT
Update
We are continuing to investigate this issue.
Posted Sep 28, 2020 - 16:02 PDT
Update
Entering emergency maintenance mode. HelloSign and HelloFax will be completely down, HelloWorks may be partially impacted
Posted Sep 28, 2020 - 16:02 PDT
Update
Still reviewing optimizations for the impacted performance areas
Posted Sep 28, 2020 - 15:51 PDT
Update
Continuing to monitor the rollout of the fix
Posted Sep 28, 2020 - 15:33 PDT
Update
We have identified a cause and a fix is being rolled out.
Posted Sep 28, 2020 - 14:42 PDT
Update
We are continuing to investigate this issue.
Posted Sep 28, 2020 - 14:02 PDT
Investigating
We are currently investigating site slowness in HelloSign and HelloFax
Posted Sep 28, 2020 - 14:02 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.