Document finalization is delayed
Incident Report for HelloSign / HelloFax
Resolved
A fix has been deployed and our metrics are showing normal latencies for document finalization.
Posted May 18, 2020 - 16:04 PDT
Update
We have identified the probable cause and are working on remediating the problem.
Posted May 18, 2020 - 14:19 PDT
Identified
We are investigating reports of PDF signature warnings on finalized documents and delays in generating new finalized documents.
Posted May 18, 2020 - 13:16 PDT
This incident affected: HelloSign.