We are currently experiencing delays in sending Sign emails to our users

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Jan 14, 2026 - 12:34 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 14, 2026 - 12:20 PST

Investigating

We are currently experiencing delays in sending Sign emails to our users. We are working to resolve the issue as quickly as possible. Thank you for your patience.
Posted Jan 14, 2026 - 12:05 PST
This incident affected: Core (Send signature requests, Finished document delivery).