Degraded Performance
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved. Thank you for your patience.
Posted Mar 10, 2022 - 17:29 PST
Monitoring
A fix has been implemented and we are continuing to monitor the results.
Posted Mar 10, 2022 - 11:57 PST
Investigating
HelloSign and HelloSign API are experiencing increased latency. We are currently investigating this issue
Posted Mar 10, 2022 - 10:57 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.