We are having performance problems with our API endpoints
Incident Report for Dropbox Sign, Fax, and Forms
Resolved
This incident has been resolved.
Posted Jun 01, 2023 - 09:00 PDT
Update
We are continuing to monitor for any further issues.
Posted Jun 01, 2023 - 07:32 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 31, 2023 - 15:12 PDT
Identified
We are seeing improved response times, but the site is still performing outside of our expectations. We are actively working to mitigate the issue. Thank you for your patience.
Posted May 31, 2023 - 10:40 PDT
Update
We are continuing to investigate this issue. Thank you for your patience while we work to resolve this issue.
Posted May 31, 2023 - 08:42 PDT
Update
We are continuing to investigate this issue. Thank you for your patience.
Posted May 30, 2023 - 16:38 PDT
Investigating
We are currently investigating performance problems with our API endpoints. The site is operational, but performing outside of our expectations. Thank you for your patience while we work to resolve this issue.
Posted May 30, 2023 - 13:01 PDT
This incident affected: API (API callbacks from Dropbox Sign).