Degraded Performance
Incident Report for HelloSign / HelloFax
Resolved
We’re back! All HelloSign features should be up and running. Thanks for bearing with us.
Posted Dec 01, 2021 - 14:03 PST
Identified
Some features are not working correctly on the HelloSign platform. Our engineers are working on the problem and all services should be back up soon.
Posted Dec 01, 2021 - 12:40 PST
This incident affected: HelloSign, HelloSign for Salesforce, and HelloSign API.