Planned Maintenance
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Aug 17, 2020 - 07:25 PDT
Update
The site and document sending is now behaving normally.
Posted Aug 17, 2020 - 07:20 PDT
Update
A side-effect of this morning's maintenance is causing slowdowns in certain processes. A fix is being deployed right now.
Posted Aug 17, 2020 - 06:38 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 17, 2020 - 00:04 PDT
Update
We are continuing to investigate this issue.
Posted Aug 16, 2020 - 23:44 PDT
Investigating
Please note, we will have scheduled maintenance of our system starting 08/16/2020 from 11:30PM PST to 12:00AM PST. Our systems will be unavailable during this time. We apologize for the inconvenience as we work to enhance your experience and our product.
Posted Aug 16, 2020 - 23:35 PDT
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.