Document generation error
Incident Report for HelloSign / HelloFax
Resolved
The issue has been resolved.
Posted 25 days ago. Jul 24, 2019 - 19:25 PDT
Investigating
We are currently experiencing errors in document generation and investigating. We will post an update once it's resolved.
Posted 25 days ago. Jul 24, 2019 - 18:02 PDT
This incident affected: HelloWorks and HelloWorks API.