HelloFax: Delayed faxes to some toll-free numbers.
Incident Report for HelloSign / HelloFax
Resolved
The upstream provider has released a fix for the service backlog.
Posted about 2 months ago. May 28, 2019 - 08:41 PDT
Identified
The issue has been identified as a large backlog of faxes at an upstream provider. The backlog is being processed.
Posted 2 months ago. May 22, 2019 - 16:10 PDT
Investigating
HelloFax is currently experiencing delayed faxes to some toll-free numbers. We are currently investigating the issue and will provide updates as we have them.
Posted 2 months ago. May 22, 2019 - 12:47 PDT
This incident affected: HelloFax.