Slowdown in document handling operations
Incident Report for HelloSign / HelloFax
Resolved
Response times have returned to normal, and all backlogs have flushed. We consider this incident resolved.
Posted 2 months ago. Jul 11, 2019 - 13:19 PDT
Monitoring
A lingering impact from the latest release has been identified as the culprit and has been rolled back. Document operations should now be responding normally.
Posted 2 months ago. Jul 11, 2019 - 12:31 PDT
Investigating
We are currently investigating a slowdown in document handling operations, such as document uploads, final document delivery, and similar events.
Posted 2 months ago. Jul 11, 2019 - 12:11 PDT
This incident affected: HelloSign, HelloFax, and HelloSign API.