Degraded service
Incident Report for HelloSign / HelloFax
Resolved
We have continued to monitor the quality of our fix, and it is holding up. Performance remains within normal bounds. This is resolved.
Posted May 02, 2022 - 11:49 PDT
Monitoring
We have identified the problem and have deployed a mitigation. Response times are improving across the board. We will continue to monitor this for the next short while.
Posted May 02, 2022 - 09:41 PDT
Investigating
We’re currently experiencing degraded services on our HelloSign and HelloFax platforms. Service is operational but may be degraded in quality. We are actively working on a resolution and will update you as soon as possible. We appreciate your patience as our team urgently works on this!
Posted May 02, 2022 - 09:02 PDT
This incident affected: HelloSign, HelloFax, and HelloSign API.