Possible login outage due to ongoing hellosign incident
Incident Report for HelloSign / HelloFax
Resolved
The underlying issue has been resolved.
Posted Jul 29, 2020 - 16:25 PDT
Monitoring
The issue with hellosign has been resolved and we're monitoring the situation.
Posted Jul 29, 2020 - 15:55 PDT
Identified
An incident causing an outage on hellosign may prevent users from logging in to helloworks. We have identified the cause of the issue and are actively working on resolving it.
Posted Jul 29, 2020 - 15:42 PDT
This incident affected: HelloWorks.