Email vendor message processing delays
Incident Report for HelloSign / HelloFax
Resolved
The incident has been resolved as reported by our vendor, as of Nov 11, 11:59 PST.
Posted Nov 11, 2020 - 12:11 PST
Monitoring
The vendor has implemented a fix and we're monitoring the results.
Posted Nov 11, 2020 - 11:39 PST
Investigating
We are experiencing email delivery delays. We are monitoring our vendor status and will update regularly as this is resolved.
Posted Nov 11, 2020 - 09:42 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, HelloWorks, HelloSign API, and HelloWorks API.