Degraded service with hellosign and hellofax.
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Feb 08, 2021 - 14:53 PST
Monitoring
The problem has been identified and a fix is being deployed. Normal service will be resuming shortly, if not already.
Posted Feb 08, 2021 - 14:18 PST
Investigating
We’re currently experiencing degraded services on our hellosign and hellofax platforms. Service is operational but may be degraded in quality. We are actively working on a resolution and will update you as soon as possible. We appreciate your patience as our team urgently works on this!
Posted Feb 08, 2021 - 14:08 PST
This incident affected: HelloSign, HelloSign for Salesforce, HelloFax, and HelloSign API.