Delays in document processing
Incident Report for HelloSign / HelloFax
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 01:26 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2020 - 00:27 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 25, 2020 - 00:04 PDT
This incident affected: HelloSign, HelloFax, and HelloSign API.