Dropbox Sign is experiencing degraded performance

Incident Report for Dropbox Sign and Fax

Resolved

This incident has been resolved.
Posted Apr 21, 2026 - 05:30 PDT

Identified

We have identified the root cause of the degradation and are are fixing it. Next update in 1 hour
Posted Apr 21, 2026 - 05:12 PDT

Investigating

We’re investigating reports of degraded performance. Our engineering team is triaging and will share updates as we learn more.
Posted Apr 21, 2026 - 05:04 PDT